Back to overview
Degraded

Performance degradation

Nov 07 at 06:00am EST

Resolved
Nov 07 at 08:20am EST

The service issue has been resolved. Thank you for your patience.

Created
Nov 07 at 06:00am EST

We are currently aware of potential issues affecting customer services, which may result in degraded performance. Our team is actively investigating to resolve the problem as quickly as possible.