Back to overview
Resolved

DataSync - Login issue

Jul 30, 2026 at 1:19pm UTC
Affected services
Cloud (United States)
Cloud (Canada)

Resolved
Jul 30, 2026 at 1:41pm UTC

The DataSync issue affecting logins in North America has been fixed. Logins are working normally again. Thank you for your patience.

Created
Jul 30, 2026 at 1:19pm UTC

We've identified an issue with DataSync that is affecting logins in North America. Our team is working on a fix